$re = '/\d{3,5}/m';
$str = '1
123
123456
1237 Main Street,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);