package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)...`)
var str = `ab
abc1234
01267
python
2 0 85 ad`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}