$re = '/.../m';
$str = 'ab
abc1234
01267
python
2 0 85 ad';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);