package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.{1,50}(?:\s|.{0,50}$)`)
var str = `Имеется длинная строка. Мне нужно разделить её на сегменты примерно по 50 символов длинной. Но чтобы слова, находящиеся на границе сегмента не разрывались, а помещались в какой-то один сегмент, это важно. Поэтому сегмент может иметь длинну 41, 45, 49 символов, неважно, главное чтобы не разрывались слова и количество символов в сегменте было примерно 50.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}