use strict;
my $str = 'Https://wWw.facebook.Com/GROUpS/2233223616820715
httpS://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
https://www.facebook.com/groups/ukrainianenglishclubrachk21312Y
https://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
Http://wWw.facebook.Com/GROUpS/hhGGGh/22332
http://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
httP://www.facebook.com/groups/ukrainianenglishclubrachk21312Y
http://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
wWw.facebook.Com/GROUpS/2233223616820715
Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
www.facebook.com/groups/ukrainianenglishclubrachk21312Y
www.facebook.com/groups/ukrainianenglishclubrachky/events/fd
facebook.Com/GROUpS/2233223616820715
FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223
facebook.com/group/ukrainianenglishclubrachk21312Y
facebook.com/groups/ukrainianenglishclubrachky/events/fd';
my $regex = qr/^(?i)(https?:\/\/)?(www\.)?facebook\.com\/group(s)?(\/?\/\d+)?(\/.*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}