package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?s)<div.*?FALSE.*?<\/div>`)
var str = `<div>
TRUE
</div>
<div>
FALSE
</div>
<div>
MAYBE
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}