import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[:|=|]\\s*([\\d|.]+)\\s*-\\s*([\\d|.]+)\\n";
final String string = "#QNT \n"
+ "Enter range :: 0.003665-0.003819\n"
+ "Sell :\n"
+ "Target 0.003912\n"
+ "Target 0.004089\n"
+ "Target 0.004267\n"
+ "SL 0.003578";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}