re = /[:|=|]\s*([\d|.]+)\s*-\s*([\d|.]+)\n/mi
str = '#QNT
Enter range :: 0.003665-0.003819
Sell :
Target 0.003912
Target 0.004089
Target 0.004267
SL 0.003578'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end