re = /^((http[s]?|ftp):\/)?\/?([^:\/\s]+)((\/\w+)*\/)([\w\-\.]+[^#?\s]+)(.*)?(#[\w\-]+)?$/m
str = 'https://www.lowcarboncontracts.uk/file/893/download?token=SI4BHJyU'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end