re = /0+$/m
str = '02011A020A060AFF4C0010055D18C66C96000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end