$re = '/(?<=\d{2})(1)(?=\d{2,4})/m';
$str = '0110812013
01108120
0112020
01108119';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);