import re
regex = re.compile(r"(?<=\d{2})(1)(?=\d{2,4})", flags=re.MULTILINE)
test_str = ("0110812013\n"
"01108120\n"
"0112020\n"
"01108119")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")