const regex = new RegExp('^(?!.*?(\\d)\\1{5})(?=(?:[a-z0-9]-?){11}$)[a-z0-9]+(?:-[a-z0-9]+){0,3}$', 'gmi')
const str = `1234567890A
12-12-3399BBB
12-12-3399BBBB
12-12-33-99B-BB
11112222BCD
11111122BCD`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}