$re = '/^(?!.*?(\d)\1{5})(?=(?:[a-z0-9]-?){11}$)[a-z0-9]+(?:-[a-z0-9]+){0,3}$/mi';
$str = '1234567890A
12-12-3399BBB
12-12-3399BBBB
12-12-33-99B-BB
11112222BCD
11111122BCD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);