const regex = /(?!Zn)(\.\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!Zn)(\\.\\s)', 'gm')
const str = `aaa. Zn. bbb
aaa. Zn. bbb.
aaa Zn. bbb.
aaa Zn. bbb
aaa Bns. bbb
aaa Bns. Bbb
aaa Zn. Aaa Bns. Bbb
1
aaa
aaa.
aaa Abbb
aaa. Zns. bbb
aaa. Zns. bbb.
aaa Zns. bbb.
aaa Zns. bbb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}