#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-za-z]{2}\d{4}|[A-za-z]{4}\d{2})"
Local $sString = "AABB12" & @CRLF & _
"BBAA12" & @CRLF & _
"AA12AA" & @CRLF & _
"BBAA12" & @CRLF & _
"AA1212"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")