re = /([A-za-z]{2}\d{4}|[A-za-z]{4}\d{2})/m
str = 'AABB12
BBAA12
AA12AA
BBAA12
AA1212'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end