$re = '/(?m)\w+(?=\h+keyword$)/';
$str = 'this is some text keyword this is some text keyword
this is some text keyword';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);