re = /(?m)\w+(?=\h+keyword$)/
str = 'this is some text keyword this is some text keyword
this is some text keyword'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end