$re = '/(?<=^|(?<=[^a-zA-Z0-9-_\.]))@([A-Za-z]+[A-Za-z0-9_]+)/';
$str = '@mickey test new @mickey_mouse
@johndoe_
@john99
@JOHN_23
// Negative cases
@9gag
@_test
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);