re = /(?<=^|(?<=[^a-zA-Z0-9-_\.]))@([A-Za-z]+[A-Za-z0-9_]+)/
str = '@mickey test new @mickey_mouse
@johndoe_
@john99
@JOHN_23
// Negative cases
@9gag
@_test
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end