using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\>([^<|]+)\<";
string input = @"</li><li><a href=""/Journal/Year/123"">Journal Title 2002</a> | <a href=""/Journal/Year/456"">2004</a> | <a href=""/Journal/Year/789"">2005</a></ul></div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}