import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\>([^<|]+)\\<";
final String string = "</li><li><a href=\"/Journal/Year/123\">Journal Title 2002</a> | <a href=\"/Journal/Year/456\">2004</a> | <a href=\"/Journal/Year/789\">2005</a></ul></div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}