using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\D[05]|[13579][05]|^[05])$";
string input = @"00
11
text1
text10
text00
text5
10
05
15
99
12345
12335
0000
0010
5
1
0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}