const regex = /(?:\D[05]|[13579][05]|^[05])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\D[05]|[13579][05]|^[05])$', 'gm')
const str = `00
11
text1
text10
text00
text5
10
05
15
99
12345
12335
0000
0010
5
1
0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}