package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s+`)
var str = `The quick brown fox jumps over the lazy dog`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}