const regex = /\s+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s+', 'gm')
const str = `The quick brown fox jumps over the lazy dog`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);