$re = '/]\(https?:\/\/docs./m';
$str = '[Temporal tables](https://docs.microsoft.com/en-us/sql/relational-databases/tables/temporal-tables)
';
$subst = "](https://learn.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;