// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)]\(https?:\/\/docs.").unwrap();
let string = "[Temporal tables](https://docs.microsoft.com/en-us/sql/relational-databases/tables/temporal-tables)
";
let substitution = "](https://learn.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}