import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((?:[+\\-\\/*]6+|6+[+\\-\\/*]|([^6]|\\b)6{1,2}(?3)|(?3)6{6,}(?3)|[0-57-9]6+|6+[0-57-9])(*SKIP)(*F))|6)";
final String string = "66\n"
+ "老铁666这类的, 6666\n"
+ "三到五个六66666\n"
+ "5666有其他数字不替换\n"
+ "6665\n"
+ "566665\n"
+ "666666\n"
+ "66\n"
+ "+66\n"
+ "666-\n";
final String subst = "六";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}