const regex = /\b([A-Z]{4}):[^\]\[\d]*(\d{1,5})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-Z]{4}):[^\\]\\[\\d]*(\\d{1,5})\\b', 'g')
const str = `08:28:57,990 DEBUG [http-0.0.0.0-18080-33] [tester] [1522412937602-580613] [TestManager] ABCD: loaded 35 test accounts`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}