re = /\b([A-Z]{4}):[^\]\[\d]*(\d{1,5})\b/
str = '08:28:57,990 DEBUG [http-0.0.0.0-18080-33] [tester] [1522412937602-580613] [TestManager] ABCD: loaded 35 test accounts'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end