package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-z0-9\.]+\@[a-z0-9]+\.com|\.org$`)
var str = `@voyager.org`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}