const regex = /^[a-z0-9\.]+\@[a-z0-9]+\.com|\.org$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-z0-9\\.]+\\@[a-z0-9]+\\.com|\\.org$', 'i')
const str = `@voyager.org`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}