const regex = /^\[\S+\s+\S+\s+\S+\s+\S+\s+\S+\] \[(\S*:)?(?:error|info)\] (\[pid \d+(:tid \d+)?\] )?\[client (\S+)\] (\w+: )?File does not exist\:/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[\\S+\\s+\\S+\\s+\\S+\\s+\\S+\\s+\\S+\\] \\[(\\S*:)?(?:error|info)\\] (\\[pid \\d+(:tid \\d+)?\\] )?\\[client (\\S+)\\] (\\w+: )?File does not exist\\:', 'gm')
const str = `[Tue Feb 09 05:02:22.769263 2021] [core:error] [pid 83886:tid 140340187059968] [client 192.168.1.133:53478] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png
[Tue Feb 09 05:02:23.986502 2021] [core:info] [pid 83885:tid 140340270987008] [client 192.168.1.133:53482] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png
[Tue Feb 09 05:02:24.480283 2021] [core:info] [pid 83885:tid 140340262594304] [client 192.168.1.133:53486] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png
[Tue Feb 09 05:02:24.882395 2021] [core:info] [pid 83886:tid 140340170274560] [client 192.168.1.133:53490] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png
[Tue Feb 09 05:02:25.224595 2021] [core:info] [pid 83884:tid 140340262594304] [client 192.168.1.133:53494] AH00128: File does not exist: /var/www/vhosts/example.com/httpdocs/test.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}