$re = '/(?<=\d\d)\d(?=\d\d)/m';
$str = '557878767';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;