import re
regex = re.compile(r"(?<=\d\d)\d(?=\d\d)", flags=re.MULTILINE)
test_str = "557878767"
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)