using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<img)(.*?)([0-9]+.imgdomain.com)(.*?)(.*?)>";
string input = @"<div class=""separator"" style=""clear: both; text-align: center;"">
<img src=""/demodomain.com/-13ucJuEQEUw/linktoimg.png""><a href=""https://12.imgdomain.com/-13ucJuEQEUw/linktoimg.png"" imageanchor=""1"" style=""margin-left: 1em; margin-right: 1em;""><img border=""0"" data-original-height=""618"" data-original-width=""1062"" height=""372"" src=""https://21.imgdomain.com/-13ucJuEQEUw/WsGsjY2E2bI/-13ucJuEQEUw/linktoimg.jpg"" width=""640""></a></div>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}