# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<img)(.*?)([0-9]+.imgdomain.com)(.*?)(.*?)>"
test_str = ("<div class=\"separator\" style=\"clear: both; text-align: center;\">\n"
"<img src=\"/demodomain.com/-13ucJuEQEUw/linktoimg.png\"><a href=\"https://12.imgdomain.com/-13ucJuEQEUw/linktoimg.png\" imageanchor=\"1\" style=\"margin-left: 1em; margin-right: 1em;\"><img border=\"0\" data-original-height=\"618\" data-original-width=\"1062\" height=\"372\" src=\"https://21.imgdomain.com/-13ucJuEQEUw/WsGsjY2E2bI/-13ucJuEQEUw/linktoimg.jpg\" width=\"640\"></a></div>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.