#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0)(?=\d{10}$)(?=.*?(.)(?:.*\1){1,2})(?!.*?(.)(?:.*\2){3})(?!.*?(?!\1)(.).*\3).*$"
Local $sString = "1234567890" & @CRLF & _
"1234537890" & @CRLF & _
"" & @CRLF & _
"1134567890" & @CRLF & _
"2123456789" & @CRLF & _
"1234267890" & @CRLF & _
"1671812342" & @CRLF & _
"1934466892:6" & @CRLF & _
"1234@56789" & @CRLF & _
"3563893124" & @CRLF & _
"4412356789" & @CRLF & _
"2349780915" & @CRLF & _
"981651321182234556" & @CRLF & _
"1234567890" & @CRLF & _
"10000000000" & @CRLF & _
"02346ex789" & @CRLF & _
"0000%00000" & @CRLF & _
"0234567 894" & @CRLF & _
"8232527884" & @CRLF & _
"02325278847" & @CRLF & _
"02345678945" & @CRLF & _
"2323456789" & @CRLF & _
"8152228374" & @CRLF & _
"0234527834" & @CRLF & _
"8183746528" & @CRLF & _
"0435465768" & @CRLF & _
"3245657689" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")