use strict;
my $str = '1234567890
1234537890
1134567890
2123456789
1234267890
1671812342
1934466892:6
1234@56789
3563893124
4412356789
2349780915
981651321182234556
1234567890
10000000000
02346ex789
0000%00000
0234567 894
8232527884
02325278847
02345678945
2323456789
8152228374
0234527834
8183746528
0435465768
3245657689
';
my $regex = qr/(?m)^(?!0)(?=\d{10}$)(?=.*?(.)(?:.*\1){1,2})(?!.*?(.)(?:.*\2){3})(?!.*?(?!\1)(.).*\3).*$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}