re = /(?:(?<=^)|(?<=\s))([a-zA-Z0-9]+)(?:(?=\s)|(?=$))/m
str = 'we don\'t have 500 dollars
Your money\'s no good here, Mr. Torrance'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end