package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[cC]ats? (?P<cat_num>\d+[A-Z]+)\b`)
var str = `Cats 5A, 5B and 5C
Cat 5A`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}