// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[cC]ats? (?P<cat_num>\d+[A-Z]+)\b").unwrap();
let string = "Cats 5A, 5B and 5C
Cat 5A";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}