use strict;
my $str = 'A1234567890 field 1 abc/def try
02021051812 12 test test 12 pass
3333G132021 no test test cancel';
my $regex = qr/^(\S+) +(\S+(?: \S+)*) +(\S+(?: \S+)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}