const regex = new RegExp('\\b(?:house|filter|table|car)\\b', 'gm')
const str = `The car in the house
You can filter the data
if you’re looking at a ship
you can filter the table to show
tablespoon
carmen
housewife
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}