re = /\b(?:house|filter|table|car)\b/m
str = 'The car in the house
You can filter the data
if you’re looking at a ship
you can filter the table to show
tablespoon
carmen
housewife
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end