#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?):([0-9]+)\->[0-9]+\/([a-z]{3})"
Local $sString = " Name Command State Ports" & @CRLF & _
"--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------" & @CRLF & _
"factorio_1 /docker-entrypoint.sh Up 0.0.0.0:27015->27015/tcp, 0.0.0.0:34197->34197/udp" & @CRLF & _
"minecraft_server /start Up (healthy) 0.0.0.0:25565->25565/tcp, 0.0.0.0:25565->25565/udp, 0.0.0.0:25575->25575/tcp, 0.0.0.0:25575->25575/udp" & @CRLF & _
"terraria_1 ./run.sh Up 0.0.0.0:7777->7777/tcp, 0.0.0.0:7777->7777/udp" & @CRLF & _
"ts3_db docker-entrypoint.sh mysqld Up 3306/tcp" & @CRLF & _
"ts3_server entrypoint.sh ts3server Up 0.0.0.0:10011->10011/tcp, 0.0.0.0:10022->10022/tcp, 0.0.0.0:10080->10080/tcp, 0.0.0.0:10443->10443/tcp, 0.0.0.0:30033->30033/tcp, 0.0.0.0:41144->41144/tcp, 0.0.0.0:9987->9987/udp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")