import re
regex = re.compile(r"\d?.(\d+.+)$", flags=re.MULTILINE)
test_str = ("Breestraat 4\n"
"Breestraat 45\n"
"Breestraat 456\n"
"Dubbele Straat 4a\n"
"Dubbele Straat 4-a\n"
"5 meistraat 1a\n"
"5meistraat 12\n"
"5meistraat 12a\n"
"Teststraat 22-III\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")