re = /\d?.(\d+.+)$/m
str = 'Breestraat 4
Breestraat 45
Breestraat 456
Dubbele Straat 4a
Dubbele Straat 4-a
5 meistraat 1a
5meistraat 12
5meistraat 12a
Teststraat 22-III
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end